• Mobile App For Android Now Online!

    Download it here. The app is searchable in the Google Play Store under Sailboat Owners.

    Sorry iPhone/iPad users, we are still waiting on Apple. :(

    Click the X in the upper right corner to make this go away

Raymarine GPS "No Fix"

May 8, 2016
14
Hunter 36 Catawba Island, Ohio
I have a C Series Raymarine chartplotter, all Raymarine instruments, and (I believe) a Raystar 125 GPS on my new-to-me 2006 Hunter 36. Everything worked on our inaugural trip, and now we have the bimini and dodger installed and most of the other bugs worked out except..... now the chartplotter is giving me the dreaded "no fix" message. The autopilot also has a "STLK FAIL" message since everything is connected via SeaTalk. For whatever reason, the GPS does not seem to be able to locate any satellites. Suggestions would be greatly appreciated.
 
Nov 13, 2013
488
Catalina 34 Tacoma
The Raymarine website has a technical support forum. Probably best to seek the advice of the experts.
 
Mar 20, 2004
1,543
Hunter 356 and 216 Portland, ME
First, make sure that the seatalk network has power - usually a plug on the back of the plotter...
Your problem is probably the rechargeable battery in the raystar - both the 120 and the 125 have one, and when it dies (it's 10 years old) the no fix is what you get. the battery preserves the last fix so it can start quickly and is soldered in. from the plotter menu, try a cold start for the GPS - that may restart it with a global search for satellites. If not, call raymarine about the repair; some people have don it themselves, but soldering a battery is tricky
 
Feb 14, 2014
4,019
Hunter 430 Saba Waveland, MS
The autopilot also has a "STLK FAIL" message since everything is connected via SeaTalk.
You get this on the autopilot when SeaTalk detects a failure of inputs to the autopilot. Since this must "Fail Safe", it should never be able to go to Auto, until the SeaTalk protocol is corrected.

Since you have a Track mode in Autopilot, that uses your Chart Plotter then "STLK FAIL"
I get no fix when something covers my GPS antenna.
Jim...

 
Sep 12, 2012
203
Hunter 450 Unspecified
Do you have the embedded GPS in the chartplotter or separate gps? Ray told me yesterday that a canvas Bimini should not interfere with their embedded GPS. But a more elaborate Bimini or solar may
 

Brian D

Moderator
Feb 17, 2006
4,527
Lancer 27PS MCB Camp Pendleton KF6BL
Even an elaborate bimini or solar would not prevent the GPS from getting some kind of signal. Not sure if the unit you have shows signal levels of the various satellites. I would think that the GPS may not be getting power. You should check for DC at the unit (if deck or rail mounted) and see if there is power there. The other possibility would be configuration.

If the backup battery is faulty or low (as mentioned above) you could have lost your configuration thus taking a very long time to try and extrapolate where the satellites are. This happens on handheld units that are turned off for any length of time. My Garmin GPS units take some time to lock if they have been off. Very normal. But they do acquire eventually. Even from inside my house.

Check power and also base configuration.
 
Jun 5, 2004
482
Hunter 44 Mystic, Ct
I think Brian has it right. I had the same problem with my Raystar 125 GPS and it turned out that the backup battery was dead and it would sometimes take up to 30 minutes to get a fix on startup. Despite what Raymarine says the battery which is a standard button battery don't recall the model number is easily replaced though you need to be careful removing the GPS cover as not to disturb anything. I think it took me about 15 minutes. Search the forum database as I and others posted some instructions about 1 or 2 years ago on how to replace the battery.
 
Dec 19, 2006
5,570
Hunter 36 Punta Gorda
Are the lights on the Raystar 120 blinking and do you have a manual for it,
also after checking the blinking lights than check wire connections in nav pod,have had wires get corroded inside my nav pod.
I have 2007 H-36 and have had no fix take a long time a few times but usually get a fix.
 
May 8, 2016
14
Hunter 36 Catawba Island, Ohio
Well, I've replaced the internal battery and it has not helped. I still have a solid red LED light on the top of the unit. Any other suggestions?
 
Feb 14, 2014
4,019
Hunter 430 Saba Waveland, MS
Any other suggestions?
Tomorrow morning I have 2 Raymarine tech on board my boat for all day. One is the best in our state. I will ask him of your error. Maybe if you "whistle up" some luck I may have an answer for you.

I have 3 separate GPS antennae on my boat...
1) Dedicated DSC FM band emergency location. ( not part of STNG)
2) The old Chartplotter
3) New built into the MFD a98 I have (2015)

I asked the RM tech how does the STNG use these signals.

1) no effect
2) Still there but does not recognize the newest 10 ( my recollection) GPS satellites.
3) I can see the GPS set up page/menu that detects maybe 25 Western Hemisphere GPS sats. But uses only 12 close ones to compute the Lat/Lon.
I asked can I use 2) ? He politely said Yes, but why?

My point: You may have not set up the Chart plotter to use the GPS that you think is on the STNG network. If not programed to use it... NO FIX! You might look at the C manual and review the GPS set up procedure.

I will chime back late tomorrow after the RM Techs leave.
Jim...
 
Mar 11, 2015
357
Hunter 33.5 Tacoma, WA
Well, I've replaced the internal battery and it has not helped. I still have a solid red LED light on the top of the unit. Any other suggestions?
Well, if the light is red, it means you at least have 12v, and since you just replaced the internal battery, it kinda points to a defective 125 (not unheard of). The green light is independent of the seatalk interface, and should work even if under/next to bimini and rails.
 
Feb 14, 2014
4,019
Hunter 430 Saba Waveland, MS
I will chime back late tomorrow after the RM Techs leave.
I asked the head RM Tech about your symptoms. He replied...
"I have taken out more C series than repaired."

But you have 3 symptoms that may be separate and distinct.
1) no fix
2) Autopilot display error
3) No satellites found.

If it is one common problem, it is SeaTalk (1) network "upsets". Guessing (bad or loose connection {signal or power} from any device on the network).
1 & 3 Could be incomplete system GPS setup. Refer to your owner's manual. This was the Tech's guess since it is easy to loose the setup info stored in the C unit.

A GPS antennae is really a passive device but the connection to SeaTalk is what makes it complex.
Jim...
 

Brian D

Moderator
Feb 17, 2006
4,527
Lancer 27PS MCB Camp Pendleton KF6BL
@catawbahunter, I went back and reread the original post. I noticed two things that stuck out at me. The first was that everything was working, then second, it stopped working after your (or someone) installed the dodger and bimini. So between those two events, something changed. Can you go back in your mind and go over everything that you did when started the install of the dodger and bimini? Think hard, something was either moved, disconnected, bumped, sat on, yelled at, or whatever. Maybe an installed screw has pierced a cable that you did not know was there.