• On September 1st, Maine Sail suffered a major hemorrhagic stroke. One of the most generous members of our sailing community, he has helped thousands. Now it's our turn. Click here to learn more

Help with B&G systems

Sep 6, 2021
6
S2 Yacht 9.2c Miami
Hey everyone, I have a S2 9.2c and we currently have a B&G Vulcan 7 chart plotter. Recently the depth has stopped displaying. I thought it was the NMEA 2000 cable that had some water and oxidation but I replaced the cable and the depth doesn’t show. If you have any suggestions on what to fix please let me know. Thanks!
 
Jan 11, 2014
7,839
Sabre 362 113 Fair Haven, NY
Is the bottom of the transducer clean?

What is the seabed like? Weeds? Soft mud? Some bottoms don't reflect the pings well, this makes it look like the sounder isn't working. Happened in my slip earlier this season, the weeds were thick and close to the hull.

Also, go into settings and device list, check to make sure the Vulcan can see the transducer.
 
Jan 11, 2014
7,839
Sabre 362 113 Fair Haven, NY
Anything else on the NMEA bus? If anything else works it isn't the cable.
And make sure the cable is properly terminated. If something has been disconnected, like the wind speed sensors the network won't work. Also if the transducer is connected to the backbone and not a drop it won't work.
 
May 17, 2004
3,474
Beneteau Oceanis 37 LE Havre de Grace
Is the depth transducer also a speed sensor? If so do you still get speed from it? If that’s the case then the cable must be fine and I’d suspect fouling on the transducer.
 
Sep 6, 2021
6
S2 Yacht 9.2c Miami
And make sure the cable is properly terminated. If something has been disconnected, like the wind speed sensors the network won't work. Also if the transducer is connected to the backbone and not a drop it won't work.
There’s my JL audio system attached which appears on the mfd so the cable going to the chart plotter works. And the transducer is attached to a drop.
 

BarryL

.
May 21, 2004
833
Jeanneau Sun Odyssey 409 Mt. Sinai, NY
Hi,

What kind of depth transducer do you have? The Vulcan can accept a SONAR transducer input, or it can use a NMEA 2000 transducer. What is connected to the back of the Vulcan?

Barry
 
Sep 6, 2021
6
S2 Yacht 9.2c Miami
Hi,

What kind of depth transducer do you have? The Vulcan can accept a SONAR transducer input, or it can use a NMEA 2000 transducer. What is connected to the back of the Vulcan?

Barry
Hey Barry. It’s an airmar transducer that uses the NMEA 2000 network. The power and NMEA cable are connected to the back.
 
Sep 6, 2021
6
S2 Yacht 9.2c Miami
Is the depth transducer also a speed sensor? If so do you still get speed from it? If that’s the case then the cable must be fine and I’d suspect fouling on the transducer.
The transducer is not responsible for the speed. Any other ideas?
 
Oct 26, 2008
5,015
Catalina 320 Barnegat, NJ
Do you have any Triton displays or just the chartplotter? If you have a separate display, does it show depth? If the transducer and cable connections seem to be fine, I'd consider that there may be in something in settings that could have been altered.
 

BarryL

.
May 21, 2004
833
Jeanneau Sun Odyssey 409 Mt. Sinai, NY
Hi,

I suggest you go into settings and then data sources. For Depth, what do you have listed and what is selected? You should be able to see the airmar transducer and then select it.

On my boat I have an airmar DST (Depth Speed Temperature). For some reason, every time the electronics get powered my Zeus loses the setting for boat speed (the 'S' part of the transducer). Every time I power up the unit I need to select the correct source for Speed Through Water. Then it works correctly. The Depth and Temperature always work. it's strange.

Good luck,
Barry


Hey Barry. It’s an airmar transducer that uses the NMEA 2000 network. The power and NMEA cable are connected to the back.
 
Nov 21, 2007
519
Beneteau Oceanis 34 Kingston, WA
Hi,

I suggest you go into settings and then data sources. For Depth, what do you have listed and what is selected? You should be able to see the airmar transducer and then select it.
:plus:
I agree with this advice and troubleshooting. Our DST transducer quit on us a couple of years ago. We'd had intermittent issues since the boat was new. Then everything quit. Since the new transducer has been installed, we get data that we never received before (temperature from our DST), and we get depth data to greater depths than we did with the original transducer.
 
Dec 28, 2015
24
Beneteau Oceanis 31 Le Crouesty Brittany
I have had the exact same problem a couple years ago. The fonction speed of the DST 800 transducer was working well but the depth was down.
After checking the connections and the system to make sure the airmar was selected, I had to change the DST 800.
 
Sep 6, 2021
6
S2 Yacht 9.2c Miami
Hi,

I suggest you go into settings and then data sources. For Depth, what do you have listed and what is selected? You should be able to see the airmar transducer and then select it.

On my boat I have an airmar DST (Depth Speed Temperature). For some reason, every time the electronics get powered my Zeus loses the setting for boat speed (the 'S' part of the transducer). Every time I power up the unit I need to select the correct source for Speed Through Water. Then it works correctly. The Depth and Temperature always work. it's strange.

Good luck,
Barry
Thanks Barry, hopefully the advice works and depth shows. Keep you updated
 
Jan 7, 2014
254
Beneteau 45F5 51551 Port Jefferson
If all else fails, borrow a buddy's NMEA transducer and see if it works. I has a problem with my wind transducer and started with B&G teh support:
Apply newest software update
Test voltage in the cable
Test the ohms across the pins etc.
Climb mast remove and mail defective unit for warranty replacement.
I could have avoided the first few steps if I had another unit to test.