Stuck Masthead Wind direction vane

Dec 28, 2010
462
Catalina 380 san pedro
I am going up the mast Saturday to find out why my masthead unit got stuck in one position. The instructions say to lubricate every year. I doubt it has ever been done. The unit is an Autohelm unit (pre Raymarine). The unit is obviously stuck as it only shows the one direction ( about 140 degrees off boat heading ) and I can see it isn't rotating to the prevailing wind from the dock. I plan on going up with a few tools and some McLube or silicone spray with a back up of a WD 40 type lube as a last resort. Any suggestions would be appreciated. Thank you in advance. We got the boat last year and it just never made it onto the "Have to get this done" list until now when it quit working.
 
Dec 28, 2010
462
Catalina 380 san pedro
Thanks SG, I'll check back in after I have a chance to go aloft. My plan is to use McLube first before I go to something petroleum. I don't want to attract any dirt if possible. I have a feeling that a bird might have rested for a while up there and...well...lets not dwell on that shall we?
 
Apr 4, 2016
201
Newport 28 Richardson Marina
WD-40 is not a lubricant it is a drier, the name means Water Displacement- formula 40, It only lubricates for a couple of weeks, stick with a teflon or silicone product.
 
Dec 28, 2010
462
Catalina 380 san pedro
Mast head.png Mast Shot.png Used a mast climber to get up the mast Saturday. Sure enough the vane wasn't turning but I was able to gently move it enough that after generously spraying some McLube into the bearings it began to work again. I was a bit short on time or I would have removed the whole unit and brought it down for an overhaul. I want to be sailing this summer not working on the boat. Here are a couple of photos.
 
Oct 22, 2014
16,409
CAL 35 Cruiser moored EVERETT WA
Nice work Kimble.
Saw this the other day in our marina. Wonder if this could be a reason your windvane got stuck.
IMG_2543.JPG