IS my 1990 Beneteau s 41S5 alternator working??

Jul 13, 2009
37
Parker Skipjack 37 Clearwater
I suspect that my 1990 Beneteau 41S5 with a Perkins Prima 50 engine might not be working. How can I tell? I waited untill the bateries were a little low at 12.1 volts per the gage on the main switchboard. Then I started the engine and reved to 2000b rpm. gage was still at 12.1 volts. However when I run the dockside 115volt AC charger the gage quckly goes to over 13volts. Help please. Thanks from Ole George
 
Nov 6, 2006
9,225
Hunter 34 Mandeville Louisiana
Alternator should push the voltage up to around 13.5-14 volts. Check all alternator connections first. Belt should be tight. If still no joy, pull it and take to an alternator shop.
 
  • Like
Likes: OWI
Feb 26, 2004
21,950
Catalina 34 224 Maple Bay, BC, Canada
Wait before you go to a shop.

How big is your house bank? How big is your alternator? Internally or externally regulated? Where are you measuring the voltage?

Without this info, your OP is meaningless.

You could have a large house bank with a tiny alternator and a big shorepower charger. The alternator is trying to increase the voltage by inputting amperage, but it could take a long time to raise the system voltage.

You may not have a problem at all.

Help us to help you, first.
 
Jul 13, 2009
37
Parker Skipjack 37 Clearwater
Thanks!, I have 2 115 Amp hour new Full River sealed batterys -always linked together. The charger is only a 10amp one. Reason I suspect alternator is that turning charger on jumps voltage up fast -yet turning engine on doesnt jump gage up. Internally regulated. Engine has 3100 hours runs fine. By the way anyone know aftermarket alternator models that fit this engine.?
 
Jan 7, 2011
2,911
Oday 322 East Chicago, IN
As soon as I turn my engine on, my system voltage goes from 12.x to 13.x Based on the voltage read at my CP.
my alternator is stock, and my bank is 205 ah flooded lead batteries.

I would suspect something isn’t working right.

Greg
 
Mar 6, 2008
690
Catalina 1999 C36 MKII #1787 Coyote Point Marina, CA.
I would not trust aftermarket alternator on a boat. It needs to not cause explosion.
 
Feb 26, 2004
21,950
Catalina 34 224 Maple Bay, BC, Canada
Alternator should push the voltage up to around 13.5-14 volts. Check all alternator connections first. Belt should be tight. If still no joy, pull it and take to an alternator shop.
Thanks!, I have 2 115 Amp hour new Full River sealed batterys -always linked together. The charger is only a 10amp one. Reason I suspect alternator is that turning charger on jumps voltage up fast -yet turning engine on doesnt jump gage up. Internally regulated. Engine has 3100 hours runs fine. By the way anyone know aftermarket alternator models that fit this engine.?
George, given this input, I suggest following kloudie's advice.
Did it ever work?
 
May 24, 2004
6,790
CC 30 South Florida
Don't you have a cockpit panel with idiot lights and a buzzer to advice of a failure of Temperature, Oil Pressure or Alternator? Given that your shore power charger goes to 13V+ I would say your alternator circuit has a fault. The easiest is to take the alternator out and have it bench tested at an electric shop. If it is the alternator get it fixed or replaced and then test the circuit connections and find out why the cockpit panel is not giving you a warning.
 
Jul 13, 2009
37
Parker Skipjack 37 Clearwater
Yes on cockpit panel-which has a indicator with a battery+- symbol .This light goes out when engine is reved up a little which I supposed indicates charging.I have never had a boat (had 11 now) which has a warning buzzer that indicates "not charging" they (buzzers) all indicated low oil or high temp.
 
May 17, 2004
3,469
Beneteau Oceanis 37 LE Havre de Grace
Yes on cockpit panel-which has a indicator with a battery+- symbol .This light goes out when engine is reved up a little which I supposed indicates charging.I have never had a boat (had 11 now) which has a warning buzzer that indicates "not charging" they (buzzers) all indicated low oil or high temp.
If it starts charging when RPMs go up then it doesn’t sound to me like a failure like fried alternator diodes. The voltage should go up more than you say it does at idle though, so I’d lean toward bad connections somewhere in the circuit.
 
  • Like
Likes: DayDreamer41
Jul 13, 2009
37
Parker Skipjack 37 Clearwater
Well I bought a new Alternator on Ebay from a dealer in Miami for $75- Installed it using wiring that was there and VIOLLA! Voltage gage shot quickly to 13.6 volts and Tach started working right away. Ony 'thing" is that the new alt has a 2.5"dia pulley while the old one was 3" dia..... so the tach reads 20% fast!! I will made a little sign near it wit the equivalent RPMs --it might be good that it does spin faster as get more juice that way! lol
 
  • Like
Likes: jssailem