Registered users don't see ads

Error 404 from New Threads / Posts List

Discussion in 'Site Talk (Forum Help)' started by Davidasailor26, Jan 12, 2019. Add this thread to a FAQ

  1. Davidasailor26

    Davidasailor26

    Joined May 17, 2004
    1,508 posts, 350 likes
    Beneteau Oceanis 37 LE
    US Havre de Grace
    It looks like there are error 404's being generated on the legacy new posts list. The links to the forum posts themselves work fine, but on any of the Recent Topics entries the link to the forum itself (eg Ask All Sailors) gets the 404.
     


  2. Brian D

    Brian D Moderator

    Joined Feb 17, 2006
    4,305 posts, 955 likes
    Lancer 27PS
    US MCB Camp Pendleton, Ca KF6BL
    I just tried a few of them and they seem to work. Now for the obligatory questions...

    Are you using desktop or smart device?
    What OS?
    What browser?

    And now for the standard "you must think I am a total internet idiot" statement...

    Did you clear your cache
    Did you reset your browser (this is just one of those "this fixes all Firefox issues")?

    Give it another try, it just might have been a glitch in the code of the Matrix.
     


  3. Davidasailor26

    Davidasailor26

    Joined May 17, 2004
    1,508 posts, 350 likes
    Beneteau Oceanis 37 LE
    US Havre de Grace
    Cleared my cache and it still seems to error. Happens on both Chrome on Android and Firefox on Windows 10. Also happens on IE which I never use and am not even logged into SBO.

    To clarify, the problem happens on https://sbo.sailboatowners.com/recent-fx.php. Under Recent Topics, I can see the link to this thread (which works), a link to my profile (which works), and a link to the Site Talk forum (broken). The forum link seems to point to https://sbo.sailboatowners.com/forumdisplay.php?f=30, rather than the actual forum URL of https://forums.sailboatowners.com/index.php?forums/site-talk-forum-help.30/
     


  4. Brian D

    Brian D Moderator

    Joined Feb 17, 2006
    4,305 posts, 955 likes
    Lancer 27PS
    US MCB Camp Pendleton, Ca KF6BL
    Yeah, it actually looks like the link has been truncated. There are missing elements

    The actual link for Site Talk is
    https://forums.sailboatowners.com/index.php?forums/site-talk-forum-help.30/

    The link you showed and produces a 404 error is
    https://sbo.sailboatowners.com/forumdisplay.php?f=30

    I now see what you are seeing and it is happening to all the forums. But only if you click on the forum name found under the title of the thread. I am not sure if it is a minor error or major. I wonder if the second link is residue from the previous version of SBO. Not sure. Let the boss take a look.

    @Phil Herring
     


    Davidasailor26 likes this.
  5. Will Gilmore

    Will Gilmore

    Joined Oct 19, 2017
    4,164 posts, 2,110 likes
    O'Day 19
    US Littleton, NH
    Awesome customer service here, Brian.
    Nice to witness.

    -Will (Dragonfly)
     


  6. Brian D

    Brian D Moderator

    Joined Feb 17, 2006
    4,305 posts, 955 likes
    Lancer 27PS
    US MCB Camp Pendleton, Ca KF6BL
    @Davidasailor26, Fearless Leader has fixed the links. They were in fact residue from several years ago. That happens when transitioning from a legacy system. Don't always get the links straighten out

    Give it a try and see if you are being redirected to the correct forum. And thanks for your troubleshooting on this matter.
     


  7. Davidasailor26

    Davidasailor26

    Joined May 17, 2004
    1,508 posts, 350 likes
    Beneteau Oceanis 37 LE
    US Havre de Grace
    Looks like they work now. Thanks Brian and Fearless Leader!
     



NEW rigid hatch covers
Hatch protection like never before. Tough, secure, installs in seconds.
Flexible steel chafe pads
Innovative new product made of flexible, laser cut stainless steel. Must see!
Leaky Lewmar ports?
Start by replacing lens gaskets in stock now
Mainsail covers
Pre-patterned mainsail covers to fit your boat